Support for TLS 1.1 and 1.2 on SharePoint 2010 and 2013

The Microsoft .NET Framework 3.5.1 now has a hotfix, KB3154518, which supports TLS 1.1 and TLS 1.2. This means that both SharePoint 2010 and 2013 now are capable of forcing TLS 1.1 and/or TLS 1.2 on the SharePoint servers, however the SharePoint Product Group currently does not fully support this. Forcing TLS 1.1/1.2 can be accomplished via registry changes or via Group Policy.

Thanks to Troy Starr and Rodney Viana for the update.

Leave a Reply